Adjective: Comparative form of nerdy: more nerdy.

rpmdb problems: $package is a duplicate with $package.

When attempting to update openssl I got the following errror:


--> Finished Dependency Resolution
Error: Package: openssl-devel-1.0.1e-16.el6_5.14.x86_64 (@updates)
           Requires: openssl = 1.0.1e-16.el6_5.14
           Removing: openssl-1.0.1e-16.el6_5.14.x86_64 (@updates)
               openssl = 1.0.1e-16.el6_5.14
           Updated By: openssl-1.0.1e-30.el6_6.5.x86_64 (updates)
               openssl = 1.0.1e-30.el6_6.5
           Removing: openssl-1.0.1e-30.el6_6.4.x86_64 (installed)
               openssl = 1.0.1e-30.el6_6.4
           Updated By: openssl-1.0.1e-30.el6_6.5.x86_64 (updates)
               openssl = 1.0.1e-30.el6_6.5
           Available: openssl-1.0.1e-30.el6.i686 (base)
               openssl = 1.0.1e-30.el6
           Available: openssl-1.0.1e-30.el6_6.2.i686 (updates)
               openssl = 1.0.1e-30.el6_6.2
 You could try using --skip-broken to work around the problem
** Found 188 pre-existing rpmdb problem(s), 'yum check' output follows:
audit-libs-2.3.7-5.el6.x86_64 is a duplicate with audit-libs-2.2-4.el6_5.x86_64
avahi-libs-0.6.25-15.el6.x86_64 is a duplicate with avahi-libs-0.6.25-12.el6_5.1.x86_64
bash-4.1.2-29.el6.x86_64 is a duplicate with bash-4.1.2-15.el6_4.x86_64
32:bind-9.8.2-0.30.rc1.el6_6.1.x86_64 is a duplicate with 32:bind-9.8.2-0.23.rc1.el6_5.1.x86_64
32:bind-devel-9.8.2-0.30.rc1.el6_6.1.x86_64 is a duplicate with 32:bind-devel-9.8.2-0.23.rc1.el6_5.1.x86_64
32:bind-libs-9.8.2-0.30.rc1.el6_6.1.x86_64 is a duplicate with 32:bind-libs-9.8.2-0.23.rc1.el6_5.1.x86_64

But will a million more duplicate, I fixed it with a forloop. Probably not the neatest but it worked fine.

for rpm in $(yum update openssl 2>/dev/null | awk '/is a duplicate with/ {print $6}'); do rpm -e $rpm --nodeps; done

Just make sure that –nodeps is there or you will have a bad time!

Leave a Reply

Your email address will not be published. Required fields are marked *